Sommaire

BONJOUR
Musique "Invention BWV784" J.S. BACH 1685-1750

DISTORSION HARMONIQUE

Etudes et réalisations


Accueil

Accueil CHM


Exploitation d'un spectre de fréquence - Maxicours

Vu dans ... https://www.maxicours.com/se/cours/exploitation-d-un-spectre-de-frequence

Spectre de fréquence

1. Spectre de fréquences
À l’aide d’un microphone relié à un oscilloscope et à un ordinateur avec carte d’acquisition, il est facile d’obtenir une courbe u = f (t) qui permet d’observer l’évolution de l’amplitude du signal (tension u) au cours de l’émission du son étudié.
On observe ainsi qu’un son complexe est composé de différents signaux sinusoïdaux de différentes fréquences.

Doc. 1. Courbe u(t) = f(t) obtenue en frottant une corde d’un violon.

À partir des données de cette courbe et à l’aide d’un logiciel d’analyse de spectre qui permet de calculer les différentes fréquences des signaux sinusoïdaux qui constituent le son complexe, on obtient le spectre de fréquence correspondant :

Doc. 2. Spectre de fréquence de la courbe du document 1.

2. Son pur et son complexe

Le spectre de fréquence d’un son pur (ou son simple) n’est composé que d’un seul pic qui correspond à la fréquence du mode de vibration fondamentale (ou simplement fréquence fondamentale).
Le spectre de fréquence d’un son complexe est composé de plusieurs pics correspondants à la fréquence du mode fondamental et celles de ses harmoniques.

a. Son pur :
         b. Son complexe :
Doc. 3. Spectres de fréquences : a. son pur ; b. son complexe.

Chaque mode de vibration est représenté par un segment de droite dont l'abscisse donne la fréquence du mode et dont la hauteur du pic est proportionnelle à l'intensité (ou amplitude) du son.
3. Caractéristiques d'un son
a. Hauteur

On associe à la hauteur d’un son la fréquence de son mode de vibration fondamentale.

Sur un spectre de fréquence, la hauteur d’un son est donc déterminée par la fréquence, f1, du premier pic.

b. Timbre
Les trois spectres de fréquence ci-dessous correspondent à la note d’un « la » obtenus par trois instruments différents : (a) un diapason, (2) une clarinette, (3) une guitare.

Doc. 4. Spectres de la note La émise par trois instruments.

Ces spectres ont même hauteur (même fréquence fondamentale) : ils correspondent bien à une même note de musique.

Ils ont des timbres différents puisqu’ils sont composés d’harmoniques de même fréquence mais d’intensités différentes (le cinquième harmonique du spectre (c) a une intensité nulle).

c. Intensité
L’intensité d’un son distingue un son fort d’un son faible. C’est ce que l’on appelle communément le volume.
Plus l’amplitude des vibrations sonores émises est grande, plus l’intensité du son émis est forte et plus les pics du spectre de fréquence ont une hauteur élevée (attention aux échelles de l’axe verticale des différents spectres obtenus).
4. Quelques applications
a. Analyse musicale
On peut analyser la composition d’un son pour le reproduire à l’identique ou pour changer certaines de ces caractéristiques, en particulier le timbre (principe des synthétiseurs de son).
On peut aussi utiliser les spectres de fréquence pour comprendre le principe de construction de la gamme tempérée, et ainsi pouvoir jouer des œuvres complexes.

Doc. 5. Spectre du Do 2 (octave 2) joué par un instrument.

On observe bien que pour une même note (le do ici), pour passer d’une octave à une autre, il suffit de multiplier la fréquence par 2 .
Le spectre en fréquence du Do 2 permet également de comprendre que, pour une oreille "européenne", l'accord majeur Do-Mi-Sol soit harmonieux, puisque ces trois notes ont des harmoniques communes.

b. La gamme tempérée
La correspondance entre une partie des notes émises par un piano et leur fréquence est représentée ci-dessous. Chaque couleur représente une octave. Pour passer d’une octave à une autre, on multiplie la fréquence de la note considérée par 2 :

Doc. 6. Fréquences des différentes notes d'un piano.

c. Principe du téléphone à fréquence vocale

La plupart des téléphones actuels sont dits à numérotation à fréquence vocale. Chaque numéro est caractérisé par sa position sur le clavier (ligne, colonne).
Lorsque l'on appuie sur une touche, le signal émis résulte de la superposition de deux signaux sinusoïdaux de fréquences distinctes, l'une caractéristique de la ligne et l'autre de la colonne (doc. 7).

 | 1 209 Hz | 1 336 Hz | 1 477 Hz
697 Hz | 1 | 2 | 3
770 Hz | 4 | 5 | 6
852 Hz | 7 | 8 | 9
941 Hz | * | 0 | #

Doc. 7. Fréquences des touches d'un téléphone.

De ce fait, le' son émis lorsqu'on appuie sur le 5 du clavier correspond à la superposition d'une sinusoïde de fréquence 770 Hz et d'une autre de fréquence 1 336 Hz.

Le spectre de fréquence du son correspondant présente deux pics (doc. 8) :

Doc. 8. Spectre de fréquence de la touche 5 du téléphone.

L'essentiel
• À partir d’un spectre de fréquence d’un son, les caractéristiques de ce son peuvent être déterminées :
– sa hauteur, caractérisée par sa fréquence du mode de vibration fondamental ;
– son timbre (il dépend de la composition des harmoniques) permet de distinguer deux notes de même hauteur jouée par deux instruments différents ;
– son intensité, liée à la hauteur des pics du spectre.

• À partir des spectres de fréquence, on peut analyser les sons et en particulier les notes et ces harmoniques qui le composent. Ce son pourra alors être reproduit à l’identique par des instruments ou par un synthétiseur de son. Il pourra être également modifié ou utilisé dans d’autres applications.


Éclaircissons les choses au sujet de la distorsion...

Vu dans ... https://www.nti-audio.com/fr/assistance/savoir-faire/%C3%A9claircissons-les-choses-au-sujet-de-la-distorsion

La distorsion est une caractéristique importante des composants audio et est souvent mentionnée dans les spécifications du produit pour les haut-parleurs, amplificateurs et autres dispositifs audio et acoustiques. Malheureusement, la terminologie est souvent utilisée de manière incorrecte ou des informations complémentaires importantes sont omises. Dans cet article, nous visons à clarifier les concepts et les méthodes de mesure ainsi que leur utilisation correcte.

Premièrement, toutes les distorsions ne sont pas mauvaises et indésirables. La distorsion peut être délibérée, par exemple le son "doux" légendaire des amplificateurs à tubes. Contrairement aux amplificateurs à transistors, les amplificateurs à tubes à vide génèrent une distorsion composée principalement d'harmoniques paires qui sont donc étroitement liées à la fréquence fondamentale. Cela produit un son qui est très agréable à l'oreille humaine.

Par contre, lorsqu'il s'agit d'enregistrer la voix ou la musique et de la reproduire au plus près de l'original, la distorsion est toujours indésirable. La classification et la mesure de ces distorsions indésirables sont examinées ci-après.

Distorsion linéaire vs. distorsion non linéaire
Une distorsion linéaire est définie comme un changement d'amplitude ou de phase sans ajout de nouvelles fréquences.

Une distorsion non linéaire se produit lorsque de nouvelles composantes de fréquence sont générées. Les distorsions non linéaires sont ce que l'on entend généralement par "distorsion".

Distorsion harmonique vs. distorsion non harmonique
Les distorsions non linéaires sont ensuite divisées en distorsions harmoniques ou non harmoniques. Dans la distorsion harmonique, tous les multiples entiers de la fréquence fondamentale sont pris en compte. Il s'agit d'une mesure classique de distorsion appelée THD (Taux de Distorsion Harmonique ou Total Harmonic Distortion en anglais). Dans les applications spéciales, le nombre total d'harmoniques spécifiques est pris en compte. Les distorsions non harmoniques sont les fréquences qui ne sont pas des multiples de la fréquence fondamentale, comme c'est le cas avec l'IMD (la distorsion d'intermodulation ou intermodulation distortion en anglais).

Spectre de distorsion harmonique

THD vs. IMD

Les appareils qui mesurent la THD sont courants et faciles à utiliser. L'inconvénient majeur des appareils à faible bande passante est que pour les signaux de test à hautes fréquences, les distorsions harmoniques sortent de la plage. Pour des lectures précises, vous avez besoin soit d'un système de mesure avec une bande passante élevée, soit de mesurer l'IMD. Pour les mesures d'IMD, deux ou plusieurs tonalités pures avec fréquence et amplitude indépendantes sont utilisées comme signaux de test. Les distorsions non linéaires produiront alors des sommes et des différences de multiples de ces fréquences d'entrée. Les distorsions sont ainsi réparties sur l'ensemble de la bande passante d'analyse.

Méthodes de mesure et de calcul
Les distorsions sont presque toujours représentées sous forme de rapports signal sur distorsion. Les résultats sont généralement exprimés en pourcentage (%) ou en décibels (dB). Les signaux de test peuvent provenir de sources audio (électrique) ou acoustique (air).

Avec la THD, il existe deux méthodes de calcul communes. La THD IEEE, utilisée principalement aux USA, est calculée comme le rapport de la distorsion à la fréquence fondamentale. La THD selon la méthode IEC est répandue à peu près partout en dehors des Etats-Unis et est calculée comme le rapport de la distorsion à la somme du signal original ET de la distorsion. Dans les systèmes de mesure plus anciens, le bruit est souvent ajouté à la distorsion, produisant une valeur THD + N (N pour le bruit). Dans tous les cas, l'amplitude de la bande passante d'analyse doit être spécifiée car cela a une influence significative sur le résultat.

Avec les mesures d'IMD, trois méthodes principales sont utilisées. La méthode MOD, conformément à la norme IEC60268/3, utilise deux tonalités avec des fréquences et amplitudes sélectionnables. Les produits d'intermodulation des harmoniques d'ordre 2-5 sont mesurés. Les méthodes DFD (Difference Frequency Distortion) et CCIF fonctionnent de manière similaire, la différence étant que les deux fréquences sont très proches l'une de l'autre et ont la même amplitude. La méthode DIM (Dynamic Intermodulation), couramment utilisée dans les tests d'amplificateurs, utilise un signal carré et une fréquence de modulation supplémentaire.

Spectre de la DFD (Difference Frequency Distortion)

Quel instrument de mesure?
Avec des systèmes de mesure plus simples, la mesure de distorsion est principalement limitée à THD+N. Pour l'analyse multicanal et complexe, un système moderne avec une large bande passante et des processeurs de signaux rapides comme l'analyseur audio FX100 est nécessaire. Grâce au logiciel PC FX-Control, tous les types de distorsion pertinents peuvent être mesurés selon les normes, rapidement, sûrement et facilement.


Taux de distorsion harmonique — Wikipédia

Taux de distorsion harmonique

Le taux de distorsion harmonique (abrégé THD, total harmonic distortion en anglais) est un indicateur de la qualité du traitement du signal dans un appareil.

Le taux de distorsion harmonique s'exprime en pourcentage. On indique le rang de l'harmonique en indice, ou on calcule le taux de distorsion harmonique total. On mesure et on communique aussi le taux de distorsion harmonique total plus bruit ((en) THD+N).

Sommaire

Théorie

Le taux de distorsion harmonique est une mesure de la linéarité du traitement du signal effectuée en comparant le signal en sortie d'un appareil à un signal d'entrée parfaitement sinusoïdal. La non-linéarité du système déforme cette sinusoïde. Le signal de sortie reste un phénomène périodique. Un signal phénomène périodique peut s'analyser en une somme de sinusoïdes de fréquences multiples de celle donnant la période, appelée fréquence fondamentale. Chacune de ces sinusoïdes est un harmonique de rang égal au quotient de sa fréquence par la fréquence fondamentale. Le taux de distorsion harmonique est le rapport des valeurs efficaces entre la fréquence fondamentale et les autres.

Le taux de distorsion harmonique d'un système varie avec le niveau et avec la fréquence du signal d'essai. Ces paramètres de la mesure doivent être spécifiés dans les procédures et les comptes rendus.

Définitions

Taux de distorsion harmonique

Le taux de distorsion harmonique se mesure normalement harmonique par harmonique dans les phases de conception et d'essai des matériels. L'indication de la répartition des harmoniques permet, en effet, de diagnostiquer l'origine des non-linéarités. Certaines formes de distorsion peuvent être plus indésirables que d'autres.

Dans une définition ancienne, on calcule le taux d'harmonique par rapport au fondamental (harmonique 1).

où h est le rang de l'harmonique, vh la valeur efficace de l'harmonique de rang h, v1 étant celle de l'harmonique 1, le fondamental1.

Comme il s'agit de sinusoïdes tant au numérateur qu'au dénominateur, le rapport des valeurs efficaces est égal à celui des amplitudes.

On obtient ainsi un tableau des taux d'harmoniques 2, 3, etc.

Dans la pratique, on mesurait le taux plutôt par rapport à la valeur efficace globale du signal de sortie. La différence est minime tant que la valeur de la distorsion harmonique totale est faible2. Mais en audio, des éléments capitaux de la chaîne de transmission, les enceintes acoustiques ont des taux de distorsion harmonique élevés. À 60 Hz, la limite d'audibilité s'élève jusqu'à 50 % de H2 et 10 % de H33. C'est pourquoi la Commission électrotechnique internationale a opté pour une définition avec la valeur efficace globale :

où h est le rang de l'harmonique, vh la valeur efficace de l'harmonique de rang h, v la valeur efficace globale et H le rang du dernier harmonique encore dans la bande passante 4.

Taux de distorsion harmonique totale

Le taux de distorsion harmonique total ((en) THD Total Harmonic Distortion) se définit comme le rapport entre la valeur efficace de l'ensemble des composantes harmoniques et la valeur efficace globale.

où vh est la valeur efficace de l'harmonique de rang h.

La même évolution que pour le taux de distorsion par harmonique s'est produite, et des mesures anciennes peuvent se référer à la valeur efficace de la fondamentale, sans que cela tire grandement à conséquence, quand les valeurs obtenues sont inférieures à 10 %.

Certains auteurs emploient les abréviations THD-G (Taux de distorsion harmonique global) pour la définition par rapport à la valeur efficace du signal de sortie et THD-F (Taux de distorsion harmonique par rapport au fondamental) pour la définition du taux par rapport à l'harmonique 1 (le fondamental), qui donne la formule suivante5 :

où Qh est la valeur efficace de l'harmonique au rang h du courant / de la tension ; Q1 est celle composante fondamentale ; QHM est la valeur efficace des courants ou tensions harmoniques ; h est le rang harmonique et H est le rang harmonique maximal, en théorie infini, en pratique, le plus élevé dans la bande passante.

Taux de distorsion harmonique plus bruit

Il est en général plus simple de mesurer l'ensemble des écarts du signal de sortie par rapport à la transmission linéaire du signal d'entrée, sans séparer les harmoniques du bruit de fond.

où v est la valeur efficace globale du signal de sortie, et v1 est la valeur efficace de l'harmonique de rang 1 (le fondamental).

Cette formule, comme les précédentes, rapporte le taux d'harmoniques à la valeur efficace globale du signal. En rapportant la valeur efficace des harmoniques à celle du fondamental, on obtient le rapport total de distorsion (TDR)6 :

où Q1 est valeur efficace de la composante fondamentale et Q est la valeur efficace totale de la grandeur (courant ou tension).

Méthodes de mesure

Le développement de l'électronique numérique a permis d'utiliser des analyseurs utilisant la transformation de Fourier rapide (FFT) permettant d'analyser la distorsion, harmonique par harmonique.

Les mesures basées sur l'intermodulation donnent une autre approche des non-linéarités des systèmes.

Les distorsions transitoires, pour lesquelles l'analyse harmonique est impossible, doivent s'évaluer par d'autres méthodes.


239 [image] [image] 240

241 [image] [image] 242

243 [image] [image] 244

245 [image] [image] 246

247 [image] [image] 248

249 [image] [image] 250

251 [image] [image] 252


DISTORSIOMETRE à PONT DOUBLE

Vu dans ... http://guitare.passion.free.fr/ampli_lampes_jnr/ampli_lampes1.htm

- Ci-après un relevé effectué par le PicoScope:

- A gauche, en bleu, l'échelle de la tension relevée sur le Haut-parleur ( soit la fondamentale à 1000 Hz ).

- A droite, en rouge, la tension relevée en sortie du distorsiomètre ( soit le résiduel du signal, les harmoniques 2 , 3 ... ).

Deux courbes types obtenues en entrée et sortie du distorsiomètre ...

- Le taux de distorsion en % s'exprime par le rapport des 2 tensions : Tdh = ( U2 x 100 ) / U1 ce qui, par exemple, et pour les 2 mesures ci-dessus donne ( 0,029 V x 100 ) / 9 V = 0,32 % à 1 kHz et à la puissance de :
P = U12 / Z = 9 V x 9 V / 8 Ω = 10,1 Watts efficaces.

Et le relevé global effectué directement sur le Haut-parleur.